獣医さんの電子工作とパソコン研究室
 
 32.ACアダプターが原因であった動作不良2台を考察する
 
  

  
このところ、続けてスイッチングハブと無線ルーターがダウンしました。 両方とも電源ランプは点灯している状態でしたので、本体基板が逝ってしまったと早とちりして、新しいものを購入してしまいました。
しかし、ジャンク箱へ行く前に解剖したところ、なんと、両者ともACアダプタがおかしかっただけでした。
本体が壊れたと思う前に、まずは電源のチェックをするという基本的な事柄のことでしたが、意外と気づかなかったりするようなものでしたので、報告します。


 その1.Switching HUB 
 
●患者:corega FSW-8PM 8ポート 100M/10M スイッチングハブ (Rev.D4) です。
 
●症状:
通常は通電しっぱなしですが、たまたま電気工事が入ったため電源を切った後から、電源を再投入しても、POWER LED は点灯するが、イニシャライズ時に順次点灯する3列あるLEDのうち、2列目3個までが繰り返し点灯する状態で、使用状況にならない。
 
●検査:
内部の目視では特に異常なし。
電源部には写真のような小型スイッチング電源。
表示は 3.3V 1A 。 UNIFIVE UL105-3315 中国製。
 
テスターで無負荷時の電圧を測定 3.37V
通電時の電圧 3.24V となっていた。
●症例の検討:
ここで、3.3Vを下回っている電圧に気づけばよかったのですが、「やはりICでも逝ってしまったか」と半分あきらめかけていたところ、ふと、通電後、LEDが順次点灯している時にデジタルテスタの表示がパラつくことに気がつく。 アナログテスタで確認しても、イニシャライズ中に若干電圧が下がるところがあり、そこからイニシャライズが最初から行われている。 なにやら電源がおかしいのか?
付属のアダプタでなく、安定化電源で3.3Vを供給すると。イニシャライズが正常に行われ、動作するではありませんか。
 
●診断結果:
付属のACアダプタの故障。
 
●修理:
自作した電子負荷にて、このアダプタの性能を測ってみる(赤線)。
  負荷とともに電圧の低下が見られ、写真のような同期の取れないリプルが増加している。
アダプタを殻割する。ドライバーを差し込むだけで簡単に外れた。よく見ると、写真白点線内のコンデンサ6.3V 1000μFが少々膨れているように見える。
 
同規格・大きさのものが手持ちになかったので、リード線を引き出して1000μFのコンデンサを新しいものに付け替え、測定。
今度は 1A負荷 で 3.16V という成績(青線)、リプルも若干見られるが、先ほどのようではなくなる。
 
この状態でハブに差し込むと、ハブは動作したが、ACアダプタの定格出力:DC1500mA@DC3.3Vより低い電圧しか出なかった。
●考察:
というわけで、原因はACアダプタにあったわけだが、このHUB、だいぶ発熱している。電源入れて数分で、放熱器を触っていられないほど熱くなっているのである。3.3V定格電圧を加えて消費電流を測定してみると、なんと1.39Aも流れているではないか。この状態は、LANケーブルをひつとも繋がない状態なので、LEDも点灯していないアイドリング状態である。これで、LEDが点灯したら、当然ACアダプタは追いつかないであろう。もしかしたら、このHUB自体が逝かれてしまっているのか、それとも最初からこんなに電力を消費しているのか?、この状態でLANケーブルを接続しても動作はしている。
coregaのホームページを見ると最大入力電流1280mAとなっているので、どうもこの基板はおかしいのかもしれない。
 その2.無線LAN 
 
●患者:BUFFALO WLAR-L11G-L 11Mbps無線LAN AirStation BroadBandルータモデル
 
●症状:無線LANステーションとして使用していたものであるが、突然POWER LEDとリンク表示1番のLEDが点灯した状態で使用不能になっていた。
●検査:まず、電圧測定。テスタではDCプラグのところで5.94Vを示すが、2つある3.3Vと5Vのレギュレーターのうち、5Vのレギュレーター(AMS 1805CM5.0)の出力電圧が4.3Vであった。

   

ACアダプタの不具合の可能性が見られたため、オシロスコープで電源波形を観測、すごいリプルであった。
そこで、安定化電源で7Vを供給、見事に動作してしまった。

●診断:
ACアダプタの故障
 
使用されていたACアダプタは
RON GER ELECTRONICS Co. 
TM-480621B
表示上の定格 DC 6V 2.1A
 
テスタで電圧を測定すると
無負荷時 8.73V

  
●修理:
いつものように殻割をした。これはケースががっちり接着剤で付いていたため、Pカッターで接合部分を削りケースを開けた。
思ったとおり、コンデンサ(4700μF 16V)の頭の部分が膨らんでいる。手持ちにこの規格のコンデンサがないので 部品箱の中にあった2200μF 16Vをつけてみた。実測データはグラフのようになる。
コンデンサを交換したACアダプタで、見事に動作するようになった。
  
●考察:
こちらの機器もACアダプタが逝ってしまっているにもかかわらず、POWERランプが点灯していたため、中のボードの故障かと思った。
WLAR-L11G-Lは、機器の裏側に6〜7V 消費電流、最大0.82Aと表示してあるが、実測値で7Vの電圧を加えると、840mA流れた。メーカーの言っている表示は本当なのか、はたして古くなったボードが電流を食うのかわからないが、疑問に残る部分がある。 
 

 3.まとめ  
 
まず、機器の故障の際には電源のチェックからという教訓を得ました。
今回の2機種は常に使用していたもので、動作しなくなったのであわてて新しいものと交換してしまったのですが、ちょっと調べれば、電源の不調だということがわかったはずです。
テスターでの電圧測定だけでなく、オシロスコープの活用や負荷に対する変動の調査が必要だということを勉強させられました。
 
時代はギガビット、高速ブロードバンドですが、まだ、私の地域では光ブロードバンドの提供はなく、ADSL 500Kの環境なので、ネットワークは古い機種で事足りています。
修理できるものは修理してとことん使いましょう。 


New release 2007/2/1

 

This page count Total:34412 / Today:5 / Yesterday:0  

 本業のページ